summaryrefslogtreecommitdiffstats
path: root/kopete/protocols/groupwise/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kopete/protocols/groupwise/CMakeLists.txt')
-rw-r--r--kopete/protocols/groupwise/CMakeLists.txt16
1 files changed, 13 insertions, 3 deletions
diff --git a/kopete/protocols/groupwise/CMakeLists.txt b/kopete/protocols/groupwise/CMakeLists.txt
index c6df3323..c129ffe8 100644
--- a/kopete/protocols/groupwise/CMakeLists.txt
+++ b/kopete/protocols/groupwise/CMakeLists.txt
@@ -9,6 +9,11 @@
#
#################################################
+if( NOT TQCA_FOUND )
+ set( TQCA_INCLUDE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/libgroupwise/qca/src )
+ set( TQCA_LIBRARIES "groupwise_tqca-static" )
+endif( )
+
add_subdirectory( icons )
add_subdirectory( libgroupwise )
add_subdirectory( ui )
@@ -18,12 +23,12 @@ include_directories(
${CMAKE_CURRENT_BINARY_DIR}/ui
${CMAKE_CURRENT_SOURCE_DIR}/libgroupwise
${CMAKE_CURRENT_SOURCE_DIR}/libgroupwise/tasks
- ${CMAKE_CURRENT_SOURCE_DIR}/libgroupwise/qca/src
${CMAKE_CURRENT_SOURCE_DIR}/ui
${CMAKE_SOURCE_DIR}/kopete/libkopete
${CMAKE_SOURCE_DIR}/kopete/libkopete/ui
${TDE_INCLUDE_DIR}
${TQT_INCLUDE_DIRS}
+ ${TQCA_INCLUDE_DIR}
)
link_directories(
@@ -33,7 +38,12 @@ link_directories(
##### other data ################################
-install( FILES kopete_groupwise.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE kopete_groupwise.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR kopete-desktops
+)
+
install( FILES gwchatui.rc DESTINATION ${DATA_INSTALL_DIR}/kopete_groupwise )
@@ -45,6 +55,6 @@ tde_add_kpart( kopete_groupwise AUTOMOC
gwconnector.cpp gwmessagemanager.cpp gwcontactlist.cpp
LINK
kopetegroupwiseui-static groupwise-static groupwise_tasks-static
- groupwise_qca-static kopete-shared
+ ${TQCA_LIBRARIES} kopete-shared
DESTINATION ${PLUGIN_INSTALL_DIR}
)