summaryrefslogtreecommitdiffstats
path: root/korganizer/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-14 19:26:10 +0200
commit3e868d844c44aab62fd1324e52872afd1f706cd3 (patch)
treeb3c06badd9b8f004ae92024d53c8bf15b8849cf0 /korganizer/CMakeLists.txt
parent9d2dbcebff2529124b4a522d3714b308548ee9ec (diff)
downloadtdepim-3e868d844c44aab62fd1324e52872afd1f706cd3.tar.gz
tdepim-3e868d844c44aab62fd1324e52872afd1f706cd3.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 0d3043b6308af148da06ac14c53defc4b1e7e138)
Diffstat (limited to 'korganizer/CMakeLists.txt')
-rw-r--r--korganizer/CMakeLists.txt22
1 files changed, 14 insertions, 8 deletions
diff --git a/korganizer/CMakeLists.txt b/korganizer/CMakeLists.txt
index a5e8aff1c..00bc3577b 100644
--- a/korganizer/CMakeLists.txt
+++ b/korganizer/CMakeLists.txt
@@ -53,21 +53,27 @@ link_directories(
tde_install_icons( )
-install( FILES
- korganizer.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE korganizer.desktop
+ PO_DIR korganizer-desktops
+)
-install( FILES
- dcopcalendar.desktop
- DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE dcopcalendar.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR korganizer-desktops
+)
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
korganizer_configmain.desktop korganizer_configtime.desktop
korganizer_configviews.desktop korganizer_configcolors.desktop
korganizer_configfonts.desktop korganizer_configplugins.desktop
korganizer_configgroupscheduling.desktop korganizer_configfreebusy.desktop
korganizer_configdesignerfields.desktop webcal.protocol
- DESTINATION ${SERVICES_INSTALL_DIR} )
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR korganizer-desktops
+)
install( FILES
uninstall.desktop