summaryrefslogtreecommitdiffstats
path: root/kresources/birthdays/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /kresources/birthdays/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kresources/birthdays/Makefile.am')
-rw-r--r--kresources/birthdays/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/kresources/birthdays/Makefile.am b/kresources/birthdays/Makefile.am
new file mode 100644
index 000000000..b7c2285fb
--- /dev/null
+++ b/kresources/birthdays/Makefile.am
@@ -0,0 +1,24 @@
+INCLUDES = -I$(top_srcdir) -I$(top_builddir) \
+ -I$(top_builddir)/kaddressbook/common \
+ -I$(top_srcdir)/kaddressbook/common \
+ $(all_includes)
+
+kde_module_LTLIBRARIES = kcal_kabc.la
+
+kcal_kabc_la_SOURCES = resourcekabc.cpp resourcekabcconfig.cpp
+kcal_kabc_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kcal_kabc_la_LIBADD = $(top_builddir)/libkcal/libkcal.la \
+ $(top_builddir)/kaddressbook/common/libkabcommon.la
+
+libkcalincludedir = $(includedir)/libkcal
+libkcalinclude_HEADERS = resourcekabc.h resourcekabcconfig.h
+
+servicedir = $(kde_servicesdir)/kresources/kcal
+service_DATA = kabc.desktop
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kres_birthday.pot
+
+resourcekabcconfig.lo: ../../kaddressbook/common/kabprefs_base.h