summaryrefslogtreecommitdiffstats
path: root/ktnef/lib/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /ktnef/lib/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'ktnef/lib/Makefile.am')
-rw-r--r--ktnef/lib/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/ktnef/lib/Makefile.am b/ktnef/lib/Makefile.am
new file mode 100644
index 000000000..731e3a377
--- /dev/null
+++ b/ktnef/lib/Makefile.am
@@ -0,0 +1,11 @@
+INCLUDES = -I$(top_srcdir)/ktnef $(all_includes)
+
+lib_LTLIBRARIES = libktnef.la
+
+libktnef_la_SOURCES = ktnefparser.cpp ktnefproperty.cpp ktnefattach.cpp mapi.cpp \
+ ktnefpropertyset.cpp ktnefmessage.cpp ktnefwriter.cpp lzfu.cpp
+libktnef_la_LIBADD = $(LIB_KDECORE) $(LIB_KIO)
+libktnef_la_LDFLAGS = $(all_libraries) -version-info 1:0:0 -no-undefined
+libktnef_la_METASOURCES = AUTO
+
+noinst_HEADERS = mapi.h lzfu.h