summaryrefslogtreecommitdiffstats
path: root/libkcal/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
commit0d3043b6308af148da06ac14c53defc4b1e7e138 (patch)
tree2e9364cb143e70ee062e443275b852b8e2061888 /libkcal/CMakeLists.txt
parent7c7363c3ca7fb9633d93cefde3cd54b144eee633 (diff)
downloadtdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.tar.gz
tdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'libkcal/CMakeLists.txt')
-rw-r--r--libkcal/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/libkcal/CMakeLists.txt b/libkcal/CMakeLists.txt
index dbded2cb4..a232a8b76 100644
--- a/libkcal/CMakeLists.txt
+++ b/libkcal/CMakeLists.txt
@@ -55,8 +55,17 @@ install( FILES
##### other data ################################
-install( FILES local.desktop localdir.desktop DESTINATION ${SERVICES_INSTALL_DIR}/tderesources/kcal )
-install( FILES kcal_manager.desktop DESTINATION ${SERVICES_INSTALL_DIR}/tderesources )
+tde_create_translated_desktop(
+ SOURCE local.desktop localdir.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/tderesources/kcal
+ PO_DIR libkcal-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE kcal_manager.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/tderesources
+ PO_DIR libkcal-desktops
+)
##### kcal_local (module) #######################