summaryrefslogtreecommitdiffstats
path: root/tderesources/groupwise/tdeioslave/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:15 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:15 -0600
commit64df902cf71a8ee258fb85f6be26248f399aa01f (patch)
treedba58f705042c22cea26b678d5b0e4e9a34bf202 /tderesources/groupwise/tdeioslave/Makefile.am
parentde53c98cab07e9c4b0f5e25dab82830fb6fc67ec (diff)
downloadtdepim-64df902cf71a8ee258fb85f6be26248f399aa01f.tar.gz
tdepim-64df902cf71a8ee258fb85f6be26248f399aa01f.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tderesources/groupwise/tdeioslave/Makefile.am')
-rw-r--r--tderesources/groupwise/tdeioslave/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/tderesources/groupwise/tdeioslave/Makefile.am b/tderesources/groupwise/tdeioslave/Makefile.am
new file mode 100644
index 000000000..e6da52837
--- /dev/null
+++ b/tderesources/groupwise/tdeioslave/Makefile.am
@@ -0,0 +1,19 @@
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/tderesources/groupwise/soap \
+ -I$(top_builddir)/libtdepim $(all_includes)
+
+noinst_HEADERS = groupwise.h
+
+METASOURCES = AUTO
+
+kdelnkdir = $(kde_servicesdir)
+kdelnk_DATA = groupwise.protocol groupwises.protocol
+
+kde_module_LTLIBRARIES = kio_groupwise.la
+
+kio_groupwise_la_SOURCES = groupwise.cpp
+kio_groupwise_la_LIBADD = $(top_builddir)/libkcal/libkcal.la \
+ ../soap/libgwsoap.la $(top_builddir)/libtdepim/libtdepim.la $(LIB_KIO)
+kio_groupwise_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/tdeio_groupwise.pot