summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-08-28 15:43:51 +0200
committerSlávek Banko <slavek.banko@axis.cz>2022-08-28 16:56:52 +0200
commit2db2a93cb4a938b0019042a2b91fc1910b572097 (patch)
tree715e68b6fc1041efe723a8b09e8be04b3fb0b89c /src/CMakeLists.txt
parent6493cf19d99f6b955982aa0488610feb77a8aad0 (diff)
downloadtdepowersave-2db2a93cb4a938b0019042a2b91fc1910b572097.tar.gz
tdepowersave-2db2a93cb4a938b0019042a2b91fc1910b572097.zip
Copy translations to a new directory layout.
Use common rules for build and install translations. Use common rules for build and install documentation. Added translation of .desktop files. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 28593cba62cd7639c6a0e3cbb4fd8508f6c9ea96)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt18
1 files changed, 14 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c5071df..210a9c6 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -30,10 +30,20 @@ link_directories(
##### other data ################################
tde_install_icons( tdepowersave )
-install( FILES tdepowersave.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
-install( FILES tdepowersave-autostart.desktop DESTINATION ${AUTOSTART_INSTALL_DIR} )
-install( FILES eventsrc DESTINATION ${DATA_INSTALL_DIR}/tdepowersave )
-install( FILES config/tdepowersaverc_default RENAME tdepowersaverc DESTINATION ${CONFIG_INSTALL_DIR} )
+tde_create_translated_desktop( tdepowersave.desktop )
+tde_create_translated_desktop(
+ SOURCE tdepowersave-autostart.desktop
+ DESTINATION ${AUTOSTART_INSTALL_DIR}
+)
+tde_create_translated_desktop(
+ SOURCE eventsrc
+ DESTINATION ${DATA_INSTALL_DIR}/tdepowersave
+)
+install(
+ FILES config/tdepowersaverc_default
+ RENAME tdepowersaverc
+ DESTINATION ${CONFIG_INSTALL_DIR}
+)
##### tdepowersave (tdeinit) ######################