summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in411
1 files changed, 0 insertions, 411 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index 77388c4..0000000
--- a/configure.in
+++ /dev/null
@@ -1,411 +0,0 @@
-dnl =======================================================
-dnl FILE: ./admin/configure.in.min
-dnl =======================================================
-
-dnl This file is part of the KDE libraries/packages
-dnl Copyright (C) 2001 Stephan Kulow (coolo@kde.org)
-
-dnl This file is free software; you can redistribute it and/or
-dnl modify it under the terms of the GNU Library General Public
-dnl License as published by the Free Software Foundation; either
-dnl version 2 of the License, or (at your option) any later version.
-
-dnl This library is distributed in the hope that it will be useful,
-dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-dnl Library General Public License for more details.
-
-dnl You should have received a copy of the GNU Library General Public License
-dnl along with this library; see the file COPYING.LIB. If not, write to
-dnl the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
-dnl Boston, MA 02110-1301, USA.
-
-# Original Author was Kalle@kde.org
-# I lifted it in some mater. (Stephan Kulow)
-# I used much code from Janos Farkas
-
-dnl Process this file with autoconf to produce a configure script.
-
-AC_INIT(acinclude.m4) dnl a source file from your sub dir
-
-dnl This is so we can use kde-common
-AC_CONFIG_AUX_DIR(admin)
-
-dnl This ksh/zsh feature conflicts with `cd blah ; pwd`
-unset CDPATH
-
-dnl Checking host/target/build systems, for make, install etc.
-AC_CANONICAL_SYSTEM
-dnl Perform program name transformation
-AC_ARG_PROGRAM
-
-dnl Automake doc recommends to do this only here. (Janos)
-AM_INIT_AUTOMAKE(tderadio, "3.5.10") dnl searches for some needed programs
-
-KDE_SET_PREFIX
-
-dnl generate the config header
-AC_CONFIG_HEADER(config.h) dnl at the distribution this done
-
-dnl Checks for programs.
-AC_PROG_CC
-AC_PROG_CXX
-TDE_CXX_COMPILE_STDCXX(11)
-AC_CHECK_COMPILERS
-AC_ENABLE_SHARED(yes)
-AC_ENABLE_STATIC(no)
-KDE_PROG_LIBTOOL
-
-dnl for NLS support. Call them in this order!
-dnl WITH_NLS is for the po files
-AM_KDE_WITH_NLS
-
-KDE_USE_TQT(3.2)
-AC_PATH_KDE
-dnl =======================================================
-dnl FILE: configure.in.in
-dnl =======================================================
-
-#MIN_CONFIG(3.2)
-
-
-CXXFLAGS="$CXXFLAGS $KDE_DEFAULT_CXXFLAGS"
-
-dnl --------------------------------------------------------------------
-dnl Check for LIRC client support
-
-PLUGIN_LIRC=
-LIB_LIRC=
-
-AC_ARG_ENABLE(lirc, AC_HELP_STRING([--enable-lirc], [enable use of LIRC if found, default = true]))
-if test -z "$enable_lirc" -o "$enable_lirc" = "yes"; then
-
- have_lirc=yes
- KDE_CHECK_LIB(lirc_client,lirc_init,,have_lirc=no)
- if test "$have_lirc" = "yes"; then
- KDE_CHECK_HEADER(lirc/lirc_client.h,,have_lirc=no)
- fi
-
- AC_MSG_CHECKING([for lirc support])
-
- if test "$have_lirc" = "yes"; then
- AC_DEFINE(HAVE_LIRC, 1, [Define this if lirc client library is available and should be used])
- LIB_LIRC="-llirc_client"
- PLUGIN_LIRC=lirc
- AC_MSG_RESULT([enabled])
- else
- AC_MSG_RESULT([disabled])
- fi
-
-
-else
-
- AC_MSG_CHECKING([for lirc support])
- AC_MSG_RESULT([disabled])
-
-fi
-
-AC_SUBST(LIB_LIRC)
-AC_SUBST(PLUGIN_LIRC)
-
-
-dnl ---------------------------------------------------------------------
-dnl V4L2
-
-
-AC_ARG_ENABLE(v4l2, AC_HELP_STRING([--enable-v4l2], [enable use of V4L2 if found, default = true]))
-if test -z "$enable_v4l2" -o "$enable_v4l2" = "yes"; then
-
- AC_MSG_CHECKING([for v4l2 support])
- AC_DEFINE_UNQUOTED(HAVE_V4L2, 1, [Define if you have V4L2 support])
- AC_MSG_RESULT([v4l2 support enabled])
-
-else
-
- AC_MSG_CHECKING([for v4l2 support])
- AC_MSG_RESULT([disabled])
-
-fi
-
-dnl ---------------------------------------------------------------------
-dnl LibSndFile
-
-AC_CHECK_LIB(sndfile, sf_open, [], AC_MSG_ERROR([libsndfile not found]))
-AC_CHECK_HEADERS([sndfile.h], [], AC_MSG_ERROR([libsndfile header not found]))
-AC_CHECK_HEADERS([sys/soundcard.h], [], AC_MSG_ERROR([sys/soundcard.h not found]))
-
-dnl ---------------------------------------------------------------------
-dnl LibLame
-
-LIB_LAME=
-
-AC_ARG_ENABLE(lame, AC_HELP_STRING([--enable-lame], [enable use of lame if found, default = true]))
-if test -z "$enable_lame" -o "$enable_lame" = "yes"; then
-
-
- have_lame=yes
- KDE_CHECK_LIB(mp3lame,lame_init,,have_lame=no)
- if test "$have_lame" = "yes"; then
- KDE_CHECK_HEADER(lame/lame.h,,have_lame=no)
- fi
-
- AC_MSG_CHECKING([for lame support])
-
- if test "$have_lame" = "yes"; then
- AC_DEFINE(HAVE_LAME, 1, [Define this if lame mp3 encoder library is available and should be used])
- LIB_LAME="-lmp3lame"
- AC_MSG_RESULT([enabled])
- else
- AC_MSG_RESULT([disabled])
- fi
-
-else
-
- AC_MSG_CHECKING([for lame support])
- AC_MSG_RESULT([disabled])
-
-fi
-
-AC_SUBST(LIB_LAME)
-
-
-dnl ---------------------------------------------------------------------
-dnl Ogg/Vorbis support
-
-LIB_OGG=
-
-AC_ARG_ENABLE(ogg, AC_HELP_STRING([--enable-ogg], [enable use of Ogg/Vorbis if found, default = true]))
-if test -z "$enable_ogg" -o "$enable_ogg" = "yes"; then
-
-
- have_ogg=yes
- KDE_CHECK_LIB(vorbisenc,vorbis_encode_init,,have_ogg=no)
- if test "$have_ogg" = "yes"; then
- KDE_CHECK_HEADER(vorbis/vorbisenc.h,,have_ogg=no)
- fi
- if test "$have_ogg" = "yes"; then
- KDE_CHECK_LIB(ogg,ogg_stream_packetin,,have_ogg=no)
- fi
- if test "$have_ogg" = "yes"; then
- KDE_CHECK_HEADER(ogg/ogg.h,,have_ogg=no)
- fi
-
- AC_MSG_CHECKING([for ogg/vorbis support])
-
- if test "$have_ogg" = "yes"; then
- AC_DEFINE(HAVE_OGG, 1, [Define this if OGG/Vorbis encoder library is available and should be used])
- LIB_OGG="-logg -lvorbisenc"
- AC_MSG_RESULT([enabled])
- else
- AC_MSG_RESULT([disabled])
- fi
-
-else
-
- AC_MSG_CHECKING([for ogg/vorbis support])
- AC_MSG_RESULT([disabled])
-
-fi
-
-AC_SUBST(LIB_OGG)
-
-dnl ---------------------------------------------------------------------
-dnl ALSA support
-
-LIB_ALSA=
-PLUGIN_ALSA=
-
-AC_ARG_ENABLE(alsa, AC_HELP_STRING([--enable-alsa], [enable use of ALSA if found, default = true]))
-if test -z "$enable_alsa" -o "$enable_alsa" = "yes"; then
-
-
- have_alsa=yes
- KDE_CHECK_LIB(asound,snd_card_next,,have_alsa=no)
- if test "$have_alsa" = "yes"; then
- KDE_CHECK_HEADER(alsa/asoundlib.h,,have_alsa=no)
- fi
-
- AC_MSG_CHECKING([for ALSA support])
-
- if test "$have_alsa" = "yes"; then
- AC_DEFINE(HAVE_ALSA, 1, [Define this if ALSA library is available and should be used])
- LIB_ALSA="-lasound"
- PLUGIN_ALSA=alsa-sound
- AC_MSG_RESULT([enabled])
- else
- AC_MSG_RESULT([disabled])
- fi
-
-else
-
- AC_MSG_CHECKING([for alsa support])
- AC_MSG_RESULT([disabled])
-
-fi
-
-AC_SUBST(LIB_ALSA)
-AC_SUBST(PLUGIN_ALSA)
-
-
-dnl ---------------------------------------------------------------------
-dnl OSS Plugin
-
-PLUGIN_OSS=
-
-AC_ARG_ENABLE(oss, AC_HELP_STRING([--enable-oss], [compile OSS plugin, default = true]))
-if test -z "$enable_oss" -o "$enable_oss" = "yes"; then
-
- PLUGIN_OSS=oss-sound
- AC_MSG_CHECKING([for OSS support])
- AC_MSG_RESULT([enabled])
-else
-
- AC_MSG_CHECKING([for OSS support])
- AC_MSG_RESULT([disabled])
-
-fi
-
-AC_SUBST(PLUGIN_OSS)
-
-
-dnl ---------------------------------------------------------------------------
-
-AC_SUBST(libtderadiodir, '$(libdir)/tderadio/plugins')
-
-
-dnl ----------------------------------------------------------------------
-dnl apidox
-KDE_INIT_DOXYGEN([The TDERadio API Reference], [Version $VERSION])
-KDE_CREATE_SUBDIRSLIST
-AC_CONFIG_FILES([ Makefile ])
-AC_CONFIG_FILES([ convert-presets/Makefile ])
-AC_CONFIG_FILES([ convert-presets/po/Makefile ])
-AC_CONFIG_FILES([ doc/Makefile ])
-AC_CONFIG_FILES([ doc/en/Makefile ])
-AC_CONFIG_FILES([ icons/Makefile ])
-AC_CONFIG_FILES([ plugins/Makefile ])
-AC_CONFIG_FILES([ plugins/alsa-sound/Makefile ])
-AC_CONFIG_FILES([ plugins/alsa-sound/icons/Makefile ])
-AC_CONFIG_FILES([ plugins/alsa-sound/po/Makefile ])
-AC_CONFIG_FILES([ plugins/gui-docking-menu/Makefile ])
-AC_CONFIG_FILES([ plugins/gui-docking-menu/po/Makefile ])
-AC_CONFIG_FILES([ plugins/gui-error-log/Makefile ])
-AC_CONFIG_FILES([ plugins/gui-error-log/po/Makefile ])
-AC_CONFIG_FILES([ plugins/gui-quickbar/Makefile ])
-AC_CONFIG_FILES([ plugins/gui-quickbar/po/Makefile ])
-AC_CONFIG_FILES([ plugins/gui-standard-display/Makefile ])
-AC_CONFIG_FILES([ plugins/gui-standard-display/po/Makefile ])
-AC_CONFIG_FILES([ plugins/lirc/Makefile ])
-AC_CONFIG_FILES([ plugins/lirc/po/Makefile ])
-AC_CONFIG_FILES([ plugins/oss-sound/Makefile ])
-AC_CONFIG_FILES([ plugins/oss-sound/icons/Makefile ])
-AC_CONFIG_FILES([ plugins/oss-sound/po/Makefile ])
-AC_CONFIG_FILES([ plugins/radio/Makefile ])
-AC_CONFIG_FILES([ plugins/radio/po/Makefile ])
-AC_CONFIG_FILES([ plugins/recording/Makefile ])
-AC_CONFIG_FILES([ plugins/recording/icons/Makefile ])
-AC_CONFIG_FILES([ plugins/recording/po/Makefile ])
-AC_CONFIG_FILES([ plugins/soundserver/Makefile ])
-AC_CONFIG_FILES([ plugins/soundserver/po/Makefile ])
-AC_CONFIG_FILES([ plugins/streaming/Makefile ])
-AC_CONFIG_FILES([ plugins/streaming/icons/Makefile ])
-AC_CONFIG_FILES([ plugins/streaming/po/Makefile ])
-AC_CONFIG_FILES([ plugins/timecontrol/Makefile ])
-AC_CONFIG_FILES([ plugins/timecontrol/icons/Makefile ])
-AC_CONFIG_FILES([ plugins/timecontrol/po/Makefile ])
-AC_CONFIG_FILES([ plugins/timeshifter/Makefile ])
-AC_CONFIG_FILES([ plugins/timeshifter/icons/Makefile ])
-AC_CONFIG_FILES([ plugins/timeshifter/po/Makefile ])
-AC_CONFIG_FILES([ plugins/v4lradio/Makefile ])
-AC_CONFIG_FILES([ plugins/v4lradio/po/Makefile ])
-AC_CONFIG_FILES([ presets/Makefile ])
-AC_CONFIG_FILES([ presets/argentina/Makefile ])
-AC_CONFIG_FILES([ presets/australia/Makefile ])
-AC_CONFIG_FILES([ presets/austria/Makefile ])
-AC_CONFIG_FILES([ presets/belarus/Makefile ])
-AC_CONFIG_FILES([ presets/belgium/Makefile ])
-AC_CONFIG_FILES([ presets/brazil/Makefile ])
-AC_CONFIG_FILES([ presets/bulgaria/Makefile ])
-AC_CONFIG_FILES([ presets/canada/Makefile ])
-AC_CONFIG_FILES([ presets/catalonia/Makefile ])
-AC_CONFIG_FILES([ presets/colombia/Makefile ])
-AC_CONFIG_FILES([ presets/croatia/Makefile ])
-AC_CONFIG_FILES([ presets/czechia/Makefile ])
-AC_CONFIG_FILES([ presets/england/Makefile ])
-AC_CONFIG_FILES([ presets/england/buckinghamshire/Makefile ])
-AC_CONFIG_FILES([ presets/finland/Makefile ])
-AC_CONFIG_FILES([ presets/france/Makefile ])
-AC_CONFIG_FILES([ presets/germany/Makefile ])
-AC_CONFIG_FILES([ presets/greece/Makefile ])
-AC_CONFIG_FILES([ presets/hungary/Makefile ])
-AC_CONFIG_FILES([ presets/iceland/Makefile ])
-AC_CONFIG_FILES([ presets/india/Makefile ])
-AC_CONFIG_FILES([ presets/ireland/Makefile ])
-AC_CONFIG_FILES([ presets/italy/Makefile ])
-AC_CONFIG_FILES([ presets/lithuania/Makefile ])
-AC_CONFIG_FILES([ presets/luxemburg/Makefile ])
-AC_CONFIG_FILES([ presets/netherlands/Makefile ])
-AC_CONFIG_FILES([ presets/new-zealand/Makefile ])
-AC_CONFIG_FILES([ presets/norway/Makefile ])
-AC_CONFIG_FILES([ presets/poland/Makefile ])
-AC_CONFIG_FILES([ presets/portugal/Makefile ])
-AC_CONFIG_FILES([ presets/romania/Makefile ])
-AC_CONFIG_FILES([ presets/russia/Makefile ])
-AC_CONFIG_FILES([ presets/slovakia/Makefile ])
-AC_CONFIG_FILES([ presets/south-africa/Makefile ])
-AC_CONFIG_FILES([ presets/spain/Makefile ])
-AC_CONFIG_FILES([ presets/sweden/Makefile ])
-AC_CONFIG_FILES([ presets/switzerland/Makefile ])
-AC_CONFIG_FILES([ presets/turkey/Makefile ])
-AC_CONFIG_FILES([ presets/ukraine/Makefile ])
-AC_CONFIG_FILES([ presets/uruguay/Makefile ])
-AC_CONFIG_FILES([ presets/usa/Makefile ])
-AC_CONFIG_FILES([ presets/vietnam/Makefile ])
-AC_CONFIG_FILES([ src/Makefile ])
-AC_CONFIG_FILES([ src/po/Makefile ])
-AC_OUTPUT
-# Check if KDE_SET_PREFIX was called, and --prefix was passed to configure
-if test -n "$kde_libs_prefix" -a -n "$given_prefix"; then
- # And if so, warn when they don't match
- if test "$kde_libs_prefix" != "$given_prefix"; then
- # And if kde doesn't know about the prefix yet
- echo ":"`tde-config --path exe`":" | grep ":$given_prefix/bin/:" 2>&1 >/dev/null
- if test $? -ne 0; then
- echo ""
- echo "Warning: you chose to install this package in $given_prefix,"
- echo "but KDE was found in $kde_libs_prefix."
- echo "For this to work, you will need to tell KDE about the new prefix, by ensuring"
- echo "that TDEDIRS contains it, e.g. export TDEDIRS=$given_prefix:$kde_libs_prefix"
- echo "Then restart KDE."
- echo ""
- fi
- fi
-fi
-
-if test x$GXX = "xyes" -a x$kde_have_gcc_visibility = "xyes" -a x$kde_cv_val_tqt_gcc_visibility_patched = "xno"; then
- echo ""
- echo "Your GCC supports symbol visibility, but the patch for TQt supporting visibility"
- echo "was not included. Therefore, GCC symbol visibility support remains disabled."
- echo ""
- echo "For better performance, consider including the TQt visibility supporting patch"
- echo "located at:"
- echo ""
- echo "http://bugs.kde.org/show_bug.cgi?id=109386"
- echo ""
- echo "and recompile all of TQt and KDE. Note, this is entirely optional and"
- echo "everything will continue to work just fine without it."
- echo ""
-fi
-
-if test "$all_tests" = "bad"; then
- if test ! "$cache_file" = "/dev/null"; then
- echo ""
- echo "Please remove the file $cache_file after changing your setup"
- echo "so that configure will find the changes next time."
- echo ""
- fi
-else
- echo ""
- echo "Good - your configure finished. Start make now"
- echo ""
-fi