summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-08-26 02:36:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-08-26 02:36:35 +0200
commit2c7714e6a1ccc5fdcfc2e1833d6c54135cdffb07 (patch)
tree28c9f93ea62372c472e2eac0cf2e1898d1a871c4 /CMakeLists.txt
downloadtdesshaskpass-2c7714e6a1ccc5fdcfc2e1833d6c54135cdffb07.tar.gz
tdesshaskpass-2c7714e6a1ccc5fdcfc2e1833d6c54135cdffb07.zip
Initial import of ksshaskpass 0.4.1.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..eaf05a3
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,17 @@
+project(ksshaskpass) # the name of your project
+
+cmake_minimum_required(VERSION 2.4.0)
+
+find_package(Qt3 REQUIRED) # find and setup Qt3 for this project
+find_package(KDE3 REQUIRED) # find and setup KDE3 for this project
+
+add_definitions(${QT_DEFINITIONS} ${KDE3_DEFINITIONS})
+
+# tell cmake where to search for libraries:
+link_directories(${KDE3_LIB_DIR})
+
+# tell cmake where to search for Qt/KDE headers:
+include_directories(${KDE3_INCLUDE_DIR} ${QT_INCLUDE_DIR})
+
+# tell cmake to process CMakeLists.txt in that subdirectory
+add_subdirectory(src)