summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..eaf05a3
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,17 @@
+project(ksshaskpass) # the name of your project
+
+cmake_minimum_required(VERSION 2.4.0)
+
+find_package(Qt3 REQUIRED) # find and setup Qt3 for this project
+find_package(KDE3 REQUIRED) # find and setup KDE3 for this project
+
+add_definitions(${QT_DEFINITIONS} ${KDE3_DEFINITIONS})
+
+# tell cmake where to search for libraries:
+link_directories(${KDE3_LIB_DIR})
+
+# tell cmake where to search for Qt/KDE headers:
+include_directories(${KDE3_INCLUDE_DIR} ${QT_INCLUDE_DIR})
+
+# tell cmake to process CMakeLists.txt in that subdirectory
+add_subdirectory(src)