summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..56dfdc7
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,10 @@
+set(ksshaskpass_SRCS
+ ksshaskpass.cpp
+)
+
+add_executable(ksshaskpass ${ksshaskpass_SRCS})
+
+target_link_libraries(ksshaskpass ${QT_LIBRARIES} kdeui kwalletclient)
+
+install(TARGETS ksshaskpass DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
+install(FILES ksshaskpass.1 DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man1)