summaryrefslogtreecommitdiffstats
path: root/kdevdesigner/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-29 22:43:34 +0200
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-08-01 17:56:29 +0900
commit96fa25303818e6107b72ba624659004751d45ad1 (patch)
tree89a7233f17e403e6b635d2ce7155d5f77a98d3d8 /kdevdesigner/src/CMakeLists.txt
parent3248c8c2f99f71bb2ca5972828754fdabacd7c90 (diff)
downloadtdevelop-96fa25303818e6107b72ba624659004751d45ad1.tar.gz
tdevelop-96fa25303818e6107b72ba624659004751d45ad1.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit fe44776673b28ca94338f23d8e7ac71593fa88ba)
Diffstat (limited to 'kdevdesigner/src/CMakeLists.txt')
-rw-r--r--kdevdesigner/src/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/kdevdesigner/src/CMakeLists.txt b/kdevdesigner/src/CMakeLists.txt
index c232cd2f..9d7378f9 100644
--- a/kdevdesigner/src/CMakeLists.txt
+++ b/kdevdesigner/src/CMakeLists.txt
@@ -23,7 +23,11 @@ link_directories(
##### other data ################################
-install( FILES kdevdesigner.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE kdevdesigner.desktop
+ PO_DIR tdevelop-desktops
+)
+
install( FILES kdevdesigner_shell.rc DESTINATION ${DATA_INSTALL_DIR}/kdevdesigner )