summaryrefslogtreecommitdiffstats
path: root/vcs/cvsservice/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-29 22:43:34 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-30 16:00:07 +0200
commitfe44776673b28ca94338f23d8e7ac71593fa88ba (patch)
treeb900146c853acbd44900bfb77a35a1af3c77aa5d /vcs/cvsservice/CMakeLists.txt
parentc0b663c4c873df495743600b8f703744420eddfa (diff)
downloadtdevelop-fe44776673b28ca94338f23d8e7ac71593fa88ba.tar.gz
tdevelop-fe44776673b28ca94338f23d8e7ac71593fa88ba.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'vcs/cvsservice/CMakeLists.txt')
-rw-r--r--vcs/cvsservice/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/vcs/cvsservice/CMakeLists.txt b/vcs/cvsservice/CMakeLists.txt
index dc50d646..ffd2eabf 100644
--- a/vcs/cvsservice/CMakeLists.txt
+++ b/vcs/cvsservice/CMakeLists.txt
@@ -30,7 +30,13 @@ link_directories(
##### other data ################################
tde_install_icons( )
-install( FILES kdevcvsservice.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+tde_create_translated_desktop(
+ SOURCE kdevcvsservice.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR tdevelop-desktops
+)
+
install( FILES kdev_cvs.png DESTINATION ${DATA_INSTALL_DIR}/kdevcvsservice/pics )
install( FILES buildcvs.sh DESTINATION ${DATA_INSTALL_DIR}/kdevcvsservice )