summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-01-03 16:34:13 +0100
committerSlávek Banko <slavek.banko@axis.cz>2020-01-09 16:49:49 +0100
commit9b7f2320aa1fa65983e8a1d921273413e76d51fd (patch)
treed1aab9698852568f6c825fa61ce1fe96560c7e08 /CMakeLists.txt
parentb8760d26ff07cb80584d677ba0d4aa4940728888 (diff)
downloadtqca-9b7f2320aa1fa65983e8a1d921273413e76d51fd.tar.gz
tqca-9b7f2320aa1fa65983e8a1d921273413e76d51fd.zip
Small adjustments to cmake conversion
+ add multiarch support for library installation path + add installation of tqcaprovider.h + removed dependency on TDE libraries Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit bd91ae659cf7e7ae03fa587aeac0753c6ec78ce2)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ba877a9..1e1ea35 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,6 +25,7 @@ include( CheckIncludeFile )
include( CheckLibraryExists )
include( CheckCSourceCompiles )
include( CheckCXXSourceCompiles )
+include( GNUInstallDirs OPTIONAL )
#### include our cmake modules
@@ -35,6 +36,10 @@ include( TDEMacros )
##### setup install paths
+if( CMAKE_INSTALL_LIBDIR )
+ tde_setup_install_path( LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}" )
+endif( )
+
include( TDESetupPaths )
tde_setup_paths( )