summaryrefslogtreecommitdiffstats
path: root/tools/assistant/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/assistant/lib/CMakeLists.txt')
-rw-r--r--tools/assistant/lib/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/tools/assistant/lib/CMakeLists.txt b/tools/assistant/lib/CMakeLists.txt
new file mode 100644
index 000000000..90746eb57
--- /dev/null
+++ b/tools/assistant/lib/CMakeLists.txt
@@ -0,0 +1,42 @@
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/mkspecs/linux-g++-64
+ ${CMAKE_BINARY_DIR}/include
+ ${ZLIB_INCLUDE_DIRS}
+)
+
+link_directories()
+
+
+##### prepare includes
+
+tqt_install_includes( ntqassistantclient.h )
+
+
+##### tqassistantclient (shared)
+
+add_definitions( -DQT_INTERNAL_NETWORK )
+
+tde_add_library( tqassistantclient SHARED
+
+ SOURCES
+ qassistantclient.cpp
+
+ LINK
+ tqt-mt-shared
+
+ VERSION 1.0.0
+
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+
+set_property(
+ TARGET tqassistantclient-shared
+ APPEND PROPERTY COMPILE_DEFINITIONS
+ QT_INTERNAL_NETWORK
+)
+
+tqt_automoc( tqassistantclient-shared )