summaryrefslogtreecommitdiffstats
path: root/tools/designer/tools/tqtcreatecw/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/designer/tools/tqtcreatecw/CMakeLists.txt')
-rw-r--r--tools/designer/tools/tqtcreatecw/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/tools/designer/tools/tqtcreatecw/CMakeLists.txt b/tools/designer/tools/tqtcreatecw/CMakeLists.txt
new file mode 100644
index 00000000..14b2f297
--- /dev/null
+++ b/tools/designer/tools/tqtcreatecw/CMakeLists.txt
@@ -0,0 +1,24 @@
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/mkspecs/linux-g++-64
+ ${CMAKE_BINARY_DIR}/include
+ ${ZLIB_INCLUDE_DIRS}
+)
+
+link_directories()
+
+
+##### tqtcreatecw (executable)
+
+set( target tqtcreatecw )
+
+tde_add_executable( ${target}
+ SOURCES main.cpp
+ LINK tqt-mt-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+tqt_automoc( ${target} )