summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am17
1 files changed, 10 insertions, 7 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index bdecbda4..0d0e6495 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -1,11 +1,7 @@
+lib_LTLIBRARIES = \
+ libxrdp-common.la
-INCLUDES = \
- -fPIC
-
-noinst_LIBRARIES = \
- libxrdp-common.a
-
-libxrdp_common_a_SOURCES = \
+libxrdp_common_la_SOURCES = \
d3des.c \
file.c \
list.c \
@@ -13,3 +9,10 @@ libxrdp_common_a_SOURCES = \
os_calls.c \
ssl_calls.c \
thread_calls.c
+
+libxrdp_common_la_LIBADD = \
+ -lcrypto \
+ -lpthread
+
+libxrdp_common_la_LDFLAGS = \
+ -version-info 5:0:5