summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 049e8af9..1bc5851f 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -18,6 +18,8 @@ AM_CPPFLAGS = \
-DXRDP_PID_PATH=\"${localstatedir}/run\" \
-DXRDP_LOG_PATH=\"${localstatedir}/log\"
+AM_CFLAGS = $(OPENSSL_CFLAGS)
+
module_LTLIBRARIES = \
libcommon.la
@@ -50,7 +52,6 @@ libcommon_la_SOURCES = \
$(PIXMAN_SOURCES)
libcommon_la_LIBADD = \
- -lcrypto \
- -lssl \
-lpthread \
+ $(OPENSSL_LIBS) \
$(DLOPEN_LIBS)