summaryrefslogtreecommitdiffstats
path: root/keygen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'keygen/Makefile.am')
-rw-r--r--keygen/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/keygen/Makefile.am b/keygen/Makefile.am
index 353f74df..25e20d50 100644
--- a/keygen/Makefile.am
+++ b/keygen/Makefile.am
@@ -13,3 +13,12 @@ xrdp_keygen_SOURCES = keygen.c
xrdp_keygen_LDADD = \
$(top_builddir)/common/libcommon.la
+
+xrdpsysconfdir = $(sysconfdir)/xrdp
+
+install-data-hook:
+ umask 077 && \
+ ./xrdp-keygen xrdp $(DESTDIR)$(xrdpsysconfdir)/rsakeys.ini
+
+uninstall-hook:
+ rm -f $(DESTDIR)$(xrdpsysconfdir)/rsakeys.ini