summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormio <stigma@disroot.org>2024-09-26 21:42:32 +1000
committermio <stigma@disroot.org>2024-09-30 19:28:14 +1000
commit460320e57786ec9a708ac7ba4191b15a305f9394 (patch)
treecffb36f3437a4895df8765f80f5a1d77f6408c95 /CMakeLists.txt
parent956d90f8cb5e5324c405ef3405b45a34d9c41d29 (diff)
downloadamarok-460320e57786ec9a708ac7ba4191b15a305f9394.tar.gz
amarok-460320e57786ec9a708ac7ba4191b15a305f9394.zip
Replace custom MP4 metadata parser with TagLib
TagLib supports MP4 metadata since version 1.6 (2009). The custom parser code caused problems because there was a mismatch between the definition of TagLib::Tag and TagLib::MP4::Tag, and the implementation of the custom TagLib::MP4::Tag. This requires TagLib 1.11 and above. Resolves: TDE/tdemultimedia#82 Signed-off-by: mio <stigma@disroot.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 238bbfd7..83acb904 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -57,7 +57,6 @@ option( WITH_NJB "Enable Nomad Jukebox support"
option( WITH_MTP "Enable MTP devices support" ${WITH_ALL_OPTIONS} )
option( WITH_IFP "Enable iRiver iFP Support" ${WITH_ALL_OPTIONS} )
option( WITH_IPOD "Enable iPod support from libgpod" ${WITH_ALL_OPTIONS} )
-option( WITH_MP4V2 "Enable MP4/AAC Tag Write Support from mp4v2" ${WITH_ALL_OPTIONS} )
option( WITH_DAAP "Enable DAAP Music Sharing Support" ${WITH_ALL_OPTIONS} )
option( WITH_EMBEDDED_SQLITE "Build with embedded Sqlite" OFF )
option( WITH_SYSTEM_SQLITE "Build with system Sqlite" ${WITH_ALL_OPTIONS} )