summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2017-01-31 02:45:44 +0100
committerSlávek Banko <slavek.banko@axis.cz>2017-01-31 02:45:44 +0100
commit117ec1e9d46baf07823a7a5719101e25e4b29e2d (patch)
tree9dde4fa0f5d3996124eafbd84bd7072f98de103f /CMakeLists.txt
parent357b4594068d36193b0fd99d1d77bb01c9db623d (diff)
downloadarts-117ec1e9d46baf07823a7a5719101e25e4b29e2d.tar.gz
arts-117ec1e9d46baf07823a7a5719101e25e4b29e2d.zip
Fix detection whether the system is big endian
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4c73f48..7e355c1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,6 +62,9 @@ tde_setup_install_path( PKGCONFIG_INSTALL_DIR "${LIB_INSTALL_DIR}/pkgconfig" )
tde_setup_architecture_flags( )
+include(TestBigEndian)
+test_big_endian(WORDS_BIGENDIAN)
+
##### check for include files ###################