summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrançois Andriot <francois.andriot@free.fr>2014-09-14 20:27:49 +0200
committerSlávek Banko <slavek.banko@axis.cz>2014-09-14 20:27:49 +0200
commitd6fd5da548d89f18642849f72295f6fbed440dfc (patch)
tree2dd18f1acaed0081e03bb959500b20cb118def85 /CMakeLists.txt
parentc73ca85a7664deae18d4b5a1671e84c558160167 (diff)
downloadarts-d6fd5da548d89f18642849f72295f6fbed440dfc.tar.gz
arts-d6fd5da548d89f18642849f72295f6fbed440dfc.zip
Add openbsd sndio support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a717527..47215ec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,6 +36,7 @@ option( WITH_VORBIS "Enable Ogg/Vorbis support" ON )
option( WITH_MAD "Enable MAD mp3 decoder support" ON )
option( WITH_ESOUND "Enable ESOUND support" ${WITH_ALL_OPTIONS} )
option( WITH_JACK "Enable JACK support" ${WITH_ALL_OPTIONS} )
+option( WITH_SNDIO "Enable SNDIO support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
@@ -188,6 +189,20 @@ if( WITH_JACK )
endif( WITH_JACK )
+##### check for SNDIO ###########################
+
+set( HAVE_LIBSNDIO 0 )
+if( WITH_SNDIO )
+ check_include_file( "sndio.h" HAVE_SNDIO_H )
+ if( HAVE_SNDIO_H )
+ set( HAVE_LIBSNDIO 1 )
+ set( LIBSNDIO_LIBRARIES "sndio" )
+ else( HAVE_SNDIO_H )
+ tde_message_fatal( "SNDIO support is requested, but `sndio.h` was not found" )
+ endif( HAVE_SNDIO_H )
+endif( WITH_SNDIO )
+
+
##### check for glib/gthread modules ############
pkg_search_module( GLIB2 glib-2.0 )