summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-02-25 15:05:47 +0100
committerSlávek Banko <slavek.banko@axis.cz>2020-04-10 12:47:23 +0200
commitce133b3eda6bddc2750800d1bb76cf3c5a947daf (patch)
treee0f684a1d9d2f50918124dd0c163eaa1d8aba621 /po/CMakeLists.txt
parentb51e232350d31b65a8cd055693c7869f0a896193 (diff)
downloadbasket-ce133b3eda6bddc2750800d1bb76cf3c5a947daf.tar.gz
basket-ce133b3eda6bddc2750800d1bb76cf3c5a947daf.zip
Conversion to the cmake building system.
Signed-off-by: gregory guy <gregory-tde@laposte.net> Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 2578c13462d6ff5f6da401c62b24c461b3b445ca)
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
new file mode 100644
index 0000000..75c89f8
--- /dev/null
+++ b/po/CMakeLists.txt
@@ -0,0 +1,14 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} NAME_WE )
+ if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
+ if( "${_po}" MATCHES "^([^/]*)/.*" )
+ string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
+ else( )
+ set( _component "${PROJECT_NAME}" )
+ endif( )
+ tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
+ endif( )
+endforeach( )