summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 10:57:17 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 10:58:46 +0900
commit0ffb5cb55667f360304b716c769a2f18035301bb (patch)
tree7e4a53e15445829b2bc873403c39f7f37d7c1192 /CMakeLists.txt
parent4bf54459fd605043d79f25a29a957b3f76ce384e (diff)
downloadbibletime-0ffb5cb55667f360304b716c769a2f18035301bb.tar.gz
bibletime-0ffb5cb55667f360304b716c769a2f18035301bb.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 57cbde6..c194bd2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -32,11 +36,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )