summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in290
1 files changed, 290 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..2907d98
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,290 @@
+dnl =======================================================
+dnl FILE: ./admin/configure.in.min
+dnl =======================================================
+
+dnl This file is part of the KDE libraries/packages
+dnl Copyright (C) 2001 Stephan Kulow (coolo@kde.org)
+
+dnl This file is free software; you can redistribute it and/or
+dnl modify it under the terms of the GNU Library General Public
+dnl License as published by the Free Software Foundation; either
+dnl version 2 of the License, or (at your option) any later version.
+
+dnl This library is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+dnl Library General Public License for more details.
+
+dnl You should have received a copy of the GNU Library General Public License
+dnl along with this library; see the file COPYING.LIB. If not, write to
+dnl the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+dnl Boston, MA 02110-1301, USA.
+
+# Original Author was Kalle@kde.org
+# I lifted it in some mater. (Stephan Kulow)
+# I used much code from Janos Farkas
+
+dnl Process this file with autoconf to produce a configure script.
+
+AC_INIT(acinclude.m4) dnl a source file from your sub dir
+
+dnl This is so we can use kde-common
+AC_CONFIG_AUX_DIR(admin)
+
+dnl This ksh/zsh feature conflicts with `cd blah ; pwd`
+unset CDPATH
+
+dnl Checking host/target/build systems, for make, install etc.
+AC_CANONICAL_SYSTEM
+dnl Perform program name transformation
+AC_ARG_PROGRAM
+
+dnl Automake doc recommends to do this only here. (Janos)
+AM_INIT_AUTOMAKE(gwenview-1.4.2, "3.5.7") dnl searches for some needed programs
+
+AM_MAINTAINER_MODE
+
+KDE_SET_PREFIX
+
+dnl generate the config header
+AM_CONFIG_HEADER(config.h) dnl at the distribution this done
+
+dnl Checks for programs.
+AC_CHECK_COMPILERS
+AC_ENABLE_SHARED(yes)
+AC_ENABLE_STATIC(no)
+KDE_PROG_LIBTOOL
+
+dnl for NLS support. Call them in this order!
+dnl WITH_NLS is for the po files
+AM_KDE_WITH_NLS
+
+KDE_USE_QT(3.2)
+AC_PATH_KDE
+dnl =======================================================
+dnl FILE: configure.in.in
+dnl =======================================================
+
+#MIN_CONFIG(3.2)
+
+KDE_ENABLE_HIDDEN_VISIBILITY
+
+KDE_CHECK_LIB(m, lround, [
+ AC_DEFINE(HAVE_LROUND, 1, [Define if you have lround])
+])
+
+#
+# KIPI
+#
+AC_ARG_WITH(kipi,
+ AC_HELP_STRING([--without-kipi], [build Gwenview without KIPI, 'KDE Image Plugin Interface']),
+ [want_kipi=$withval],
+ [want_kipi=yes]
+)
+
+if test "$want_kipi" = "yes"; then
+ AC_MSG_NOTICE(checking if KIPI is installed)
+ KDE_CHECK_HEADER(libkipi/interface.h,
+ have_kipi=yes,
+ have_kipi=no)
+
+ if test "$have_kipi" = "yes"; then
+ AC_DEFINE(GV_HAVE_KIPI, 1, [If we have libkipi installed])
+ GV_LIB_KIPI="-lkipi"
+ AC_SUBST(GV_LIB_KIPI)
+ else
+ AC_MSG_WARN([KIPI is not installed. Gwenview will be build without KIPI support.])
+ fi
+fi
+
+#
+# Imlib/Mosfet scaling
+#
+AM_PROG_AS
+
+# MMX test duped from kdelibs/kdefx - it should be probably moved to admin/
+dnl -----------------------------------------------------
+dnl IA32 checks
+dnl -----------------------------------------------------
+
+gv_asm_defs=
+case $host_cpu in
+ i*86 )
+ AC_MSG_CHECKING(for assembler support for IA32 extensions)
+
+ dnl MMX check
+ AC_TRY_COMPILE(, [ __asm__("pxor %mm0, %mm0") ],
+ [
+ echo $ECHO_N "MMX yes$ECHO_C"
+ AC_DEFINE_UNQUOTED(HAVE_X86_MMX, 1, [Define to 1 if the assembler supports MMX instructions.])
+ gv_asm_defs="$gv_asm_defs -DHAVE_X86_MMX"
+ ], [ echo $ECHO_N "MMX no$ECHO_C" ])
+
+ dnl SSE check
+ AC_TRY_COMPILE(,[ __asm__("xorps %xmm0, %xmm0") ],
+ [
+ echo $ECHO_N ", SSE yes$ECHO_C"
+ AC_DEFINE_UNQUOTED(HAVE_X86_SSE, 1, [Define to 1 if the assembler supports SSE instructions.])
+ gv_asm_defs="$gv_asm_defs -DHAVE_X86_SSE"
+ ], [ echo $ECHO_N ", SSE no$ECHO_C" ])
+
+ dnl SSE2 check
+ AC_TRY_COMPILE(, [ __asm__("xorpd %xmm0, %xmm0") ],
+ [
+ echo $ECHO_N ", SSE2 yes$ECHO_C"
+ AC_DEFINE_UNQUOTED(HAVE_X86_SSE2, 1, [Define to 1 if the assembler supports SSE2 instructions.])
+ gv_asm_defs="$gv_asm_defs -DHAVE_X86_SSE2"
+ ], [ echo $ECHO_N ", SSE2 no$ECHO_C" ])
+
+ dnl 3DNOW check
+ AC_TRY_COMPILE(, [ __asm__("femms") ],
+ [
+ echo $ECHO_N ", 3DNOW yes$ECHO_C"
+ AC_DEFINE_UNQUOTED(HAVE_X86_3DNOW, 1, [Define to 1 if the assembler supports 3DNOW instructions.])
+ gv_asm_defs="$gv_asm_defs -DHAVE_X86_3DNOW"
+ ], [ echo $ECHO_N ", 3DNOW no$ECHO_C" ])
+ echo
+ ;;
+ powerpc )
+ AC_MSG_CHECKING(for assembler support for AltiVec instructions)
+ dnl AltiVec check
+ AC_TRY_COMPILE(, [ __asm__("mtspr 256, %0\n\t" "vand %%v0, %%v0, %%v0" : : "r"(-1) ) ],
+ [
+ echo $ECHO_N " yes$ECHO_C"
+ AC_DEFINE_UNQUOTED(HAVE_PPC_ALTIVEC, 1, [Define to 1 if the assembler supports AltiVec instructions.])
+ gv_asm_defs="$gv_asm_defs -DHAVE_PPC_ALTIVEC"
+ ], [ echo $ECHO_N ", AltiVec no$ECHO_C" ])
+ echo
+ ;;
+esac
+
+GV_ASM_DEFS="$gv_asm_defs"
+AC_SUBST(GV_ASM_DEFS)
+
+#
+# libmng check (for gvmngformattype.*)
+#
+LIBMNG=
+KDE_CHECK_HEADER(libmng.h,
+ [
+ KDE_CHECK_LIB(mng, mng_initialize,
+ [
+ AC_DEFINE_UNQUOTED(HAVE_LIBMNG, 1, [Define if you have libmng])
+ LIBMNG="-lmng $LIBZ -lm"
+ ], [], $LIBZ -lm)
+ ])
+AC_SUBST(LIBMNG)
+if test -z "$LIBMNG"; then
+ AC_WARN([Can't find libmng.h, Gwenview won't be compiled with MNG support])
+fi
+
+
+#
+# libxcursor
+#
+KDE_CHECK_HEADERS(X11/Xcursor/Xcursor.h,
+ [KDE_CHECK_LIB(Xcursor, XcursorXcFileLoadImages, [
+ GV_LIB_XCURSOR=-lXcursor
+ AC_DEFINE_UNQUOTED(GV_HAVE_XCURSOR, 1, [Define to 1 if you have Xcursor])
+ ], [ GV_LIB_XCURSOR= ], [ $X_PRE_LIBS -lX11 $X_EXTRA_LIBS ])],
+ [ GV_LIB_XCURSOR= ], [#include <X11/Xlib.h>])
+AC_SUBST(GV_LIB_XCURSOR)
+if test -z "$GV_LIB_XCURSOR"; then
+ AC_WARN([Can't find Xcursor.h, Gwenview won't be compiled with X cursor support])
+fi
+
+
+#
+# libexiv2
+#
+KDE_CHECK_HEADERS(exiv2/image.hpp, have_exiv2=yes, have_exiv2=no)
+
+if test "$have_exiv2" = "yes"; then
+ LIB_EXIV2="-lexiv2"
+ AC_SUBST(LIB_EXIV2)
+else
+ AC_MSG_ERROR([You are missing libexiv2, which is required to compile Gwenview])
+ DO_NOT_COMPILE="$DO_NOT_COMPILE gwenview"
+fi
+KDE_CREATE_SUBDIRSLIST
+AM_CONDITIONAL(doc_SUBDIR_included, test "x$doc_SUBDIR_included" = xyes)
+AM_CONDITIONAL(src_SUBDIR_included, test "x$src_SUBDIR_included" = xyes)
+AC_CONFIG_FILES([ Makefile ])
+AC_CONFIG_FILES([ doc/Makefile ])
+AC_CONFIG_FILES([ src/Makefile ])
+AC_CONFIG_FILES([ src/app/Makefile ])
+AC_CONFIG_FILES([ src/desktopfiles/Makefile ])
+AC_CONFIG_FILES([ src/doc/Makefile ])
+AC_CONFIG_FILES([ src/gvcore/Makefile ])
+AC_CONFIG_FILES([ src/gvdirpart/Makefile ])
+AC_CONFIG_FILES([ src/gvimagepart/Makefile ])
+AC_CONFIG_FILES([ src/imageutils/Makefile ])
+AC_CONFIG_FILES([ src/pics/Makefile ])
+AC_CONFIG_FILES([ src/pics/action/Makefile ])
+AC_CONFIG_FILES([ src/pics/app/Makefile ])
+AC_CONFIG_FILES([ src/pics/cursor/Makefile ])
+AC_CONFIG_FILES([ src/pics/thumbnail/Makefile ])
+AC_CONFIG_FILES([ src/tools/Makefile ])
+AC_CONFIG_FILES([ src/tsthread/Makefile ])
+AC_CONFIG_FILES([ src/updates/Makefile ])
+AC_OUTPUT
+if test "$want_kipi" = "yes" ; then
+ if test "$have_kipi" != "yes" ; then
+ echo ""
+ echo "KIPI is not installed. Gwenview will be build without KIPI support."
+ echo ""
+ fi
+else
+ echo ""
+ echo "KIPI support has been disabled. Gwenview will be build without KIPI support."
+ echo ""
+fi
+dnl Put here things to be done at the very end - telling users
+dnl about additional packages to install. Better yet is giving
+dnl each project / subdr its own configure.in.bot.
+
+# Check if KDE_SET_PREFIX was called, and --prefix was passed to configure
+if test -n "$kde_libs_prefix" -a -n "$given_prefix"; then
+ # And if so, warn when they don't match
+ if test "$kde_libs_prefix" != "$given_prefix"; then
+ # And if kde doesn't know about the prefix yet
+ echo ":"`kde-config --path exe`":" | grep ":$given_prefix/bin/:" 2>&1 >/dev/null
+ if test $? -ne 0; then
+ echo ""
+ echo "Warning: you chose to install this package in $given_prefix,"
+ echo "but KDE was found in $kde_libs_prefix."
+ echo "For this to work, you will need to tell KDE about the new prefix, by ensuring"
+ echo "that KDEDIRS contains it, e.g. export KDEDIRS=$given_prefix:$kde_libs_prefix"
+ echo "Then restart KDE."
+ echo ""
+ fi
+ fi
+fi
+
+if test x$GXX = "xyes" -a x$kde_have_gcc_visibility = "xyes" -a x$kde_cv_val_qt_gcc_visibility_patched = "xno"; then
+ echo ""
+ echo "Your GCC supports symbol visibility, but the patch for Qt supporting visibility"
+ echo "was not included. Therefore, GCC symbol visibility support remains disabled."
+ echo ""
+ echo "For better performance, consider including the Qt visibility supporting patch"
+ echo "located at:"
+ echo ""
+ echo "http://bugs.kde.org/show_bug.cgi?id=109386"
+ echo ""
+ echo "and recompile all of Qt and KDE. Note, this is entirely optional and"
+ echo "everything will continue to work just fine without it."
+ echo ""
+fi
+
+if test "$all_tests" = "bad"; then
+ if test ! "$cache_file" = "/dev/null"; then
+ echo ""
+ echo "Please remove the file $cache_file after changing your setup"
+ echo "so that configure will find the changes next time."
+ echo ""
+ fi
+else
+ echo ""
+ echo "Good - your configure finished. Start make now"
+ echo ""
+fi