summaryrefslogtreecommitdiffstats
path: root/k9devices/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'k9devices/Makefile.am')
-rw-r--r--k9devices/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/k9devices/Makefile.am b/k9devices/Makefile.am
new file mode 100644
index 0000000..c939086
--- /dev/null
+++ b/k9devices/Makefile.am
@@ -0,0 +1,10 @@
+INCLUDES = -I$(top_srcdir)/dvdread -I$(top_srcdir)/libk9copy $(DBUS_INCS) \
+ $(HAL_INCS) $(K3B_INCS) $(all_includes)
+METASOURCES = AUTO
+libk9devices_la_LDFLAGS = $(all_libraries)
+noinst_LTLIBRARIES = libk9devices.la
+noinst_HEADERS = k9halconnection.h k9haldevice.h k9cddrive.h k9dbusdispatch.h
+libk9devices_la_SOURCES = k9halconnection.cpp k9haldevice.cpp k9cddrive.cpp \
+ k9dbusdispatch.cpp
+
+libk9devices_la_LIBADD = $(K3B_LIBS) $(HAL_DBUS_LIBS)