summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..9061415
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,27 @@
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${NSPR_INCLUDE_DIRS}
+ ${X11_INCLUDE_DIR}
+ ${X11_Xt_INCLUDE_PATH}
+ ${LIBXAW7_INCLUDE_DIRS}
+)
+
+
+##### kaffeineplugin (module)
+
+tde_add_library( kaffeineplugin MODULE
+
+ SOURCES
+ plugin.c
+ npunix.c
+ LINK
+ ${X11_LIBRARIES}
+ ${X11_Xt_LIB}
+ ${LIBXAW7_LIBRARIES}
+ ${MATH_LIBC}
+
+ DESTINATION ${LIB_INSTALL_DIR}/mozilla/plugins
+)