summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 11:06:22 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 11:00:55 +0900
commitd559e675c8ac630f5c55b910931b1f054b0d9e97 (patch)
tree3e44881a81d33cd47831eeda9adedfa92f4309a3 /CMakeLists.txt
parent5110b0e8024d655ce89d79ffea993e3dc267067d (diff)
downloadkatapult-d559e675c8ac630f5c55b910931b1f054b0d9e97.tar.gz
katapult-d559e675c8ac630f5c55b910931b1f054b0d9e97.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 86a7d31..49398f0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )