summaryrefslogtreecommitdiffstats
path: root/fileplugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fileplugin/Makefile.am')
-rw-r--r--fileplugin/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/fileplugin/Makefile.am b/fileplugin/Makefile.am
new file mode 100644
index 0000000..83e54db
--- /dev/null
+++ b/fileplugin/Makefile.am
@@ -0,0 +1,18 @@
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+kde_module_LTLIBRARIES = kfile_kbarcode.la
+
+kfile_kbarcode_la_SOURCES = kfile_kbarcode.cpp
+kfile_kbarcode_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+kfile_kbarcode_la_LIBADD = $(LIB_KSYCOCA) $(LIB_KDECORE)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+# messages: rc.cpp
+# $(XGETTEXT) *.cpp -o $(podir)/kfile_kbarcode.pot
+
+services_DATA = kfile_kbarcode.desktop
+servicesdir = $(kde_servicesdir)
+