summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-25 16:01:59 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-27 00:21:39 +0200
commit9d44dbef4aff3818594d4f45d861c1c4aa5c7116 (patch)
tree2528852157b34263497777292b15e761f91eb4e2 /src/CMakeLists.txt
parent230cf2cbfbc4561df749fbf2b00ff18d75ea5531 (diff)
downloadkbookreader-9d44dbef4aff3818594d4f45d861c1c4aa5c7116.tar.gz
kbookreader-9d44dbef4aff3818594d4f45d861c1c4aa5c7116.zip
Rename installed files to kbookreader.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 50e6395..2e3332c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -14,7 +14,7 @@ link_directories(
##### bookreader (executable)
-tde_add_executable( bookreader AUTOMOC
+tde_add_executable( ${PROJECT_NAME} AUTOMOC
SOURCES
settingsdlg.ui
@@ -39,7 +39,7 @@ tde_add_executable( bookreader AUTOMOC
##### bookreader_client (executable)
-tde_add_executable( bookreader_client AUTOMOC
+tde_add_executable( ${PROJECT_NAME}_client AUTOMOC
SOURCES
bookreader_client.cpp
@@ -60,13 +60,13 @@ tde_install_icons( )
##### other data
install(
- FILES bookreaderui.rc
- DESTINATION ${DATA_INSTALL_DIR}/bookreader
+ FILES kbookreaderui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}
)
-tde_create_translated_desktop( bookreader.desktop )
+tde_create_translated_desktop( ${PROJECT_NAME}.desktop )
install(
- FILES bookreader.kcfg
+ FILES ${PROJECT_NAME}.kcfg
DESTINATION ${KCFG_INSTALL_DIR}
)