summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 50e6395..2e3332c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -14,7 +14,7 @@ link_directories(
##### bookreader (executable)
-tde_add_executable( bookreader AUTOMOC
+tde_add_executable( ${PROJECT_NAME} AUTOMOC
SOURCES
settingsdlg.ui
@@ -39,7 +39,7 @@ tde_add_executable( bookreader AUTOMOC
##### bookreader_client (executable)
-tde_add_executable( bookreader_client AUTOMOC
+tde_add_executable( ${PROJECT_NAME}_client AUTOMOC
SOURCES
bookreader_client.cpp
@@ -60,13 +60,13 @@ tde_install_icons( )
##### other data
install(
- FILES bookreaderui.rc
- DESTINATION ${DATA_INSTALL_DIR}/bookreader
+ FILES kbookreaderui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}
)
-tde_create_translated_desktop( bookreader.desktop )
+tde_create_translated_desktop( ${PROJECT_NAME}.desktop )
install(
- FILES bookreader.kcfg
+ FILES ${PROJECT_NAME}.kcfg
DESTINATION ${KCFG_INSTALL_DIR}
)