summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-08-01 10:50:42 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-08-01 10:50:42 +0200
commit4fb1946f4b5dae37428f7f052851605727454e3d (patch)
tree205068968cf1b0a342c2f826aa7e95cc133b75e0 /CMakeLists.txt
parent3723e031627c43822f27a3958ef03e5a1608688f (diff)
downloadkchmviewer-4fb1946f4b5dae37428f7f052851605727454e3d.tar.gz
kchmviewer-4fb1946f4b5dae37428f7f052851605727454e3d.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9fa1392..95460ed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,8 +72,14 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( lib )
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+if( WITH_TDE )
+ tde_conditional_add_project_docs( BUILD_DOC )
+ tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+endif()
##### write configure files