summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-05-26 02:11:54 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-05-26 02:11:54 -0500
commit15cbe6d94327f69b793312be6b6b132bb50af651 (patch)
tree30eb3e89ef061b60ce7745491e74a27cfd508f06 /src/Makefile.am
downloadkcmldapmanager-15cbe6d94327f69b793312be6b6b132bb50af651.tar.gz
kcmldapmanager-15cbe6d94327f69b793312be6b6b132bb50af651.zip
Initial import of skeletal module for further development
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..dc6eb14
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,19 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = kcm_ldap.la
+
+kcm_ldap_la_SOURCES = ldap.cpp ldapconfigbase.ui
+kcm_ldap_la_LIBADD = -lkio $(LIB_TDEUI)
+kcm_ldap_la_LDFLAGS = -avoid-version -module -no-undefined \
+ $(all_libraries)
+
+
+xdg_apps_DATA = ldap.desktop
+
+
+messages: rc.cpp
+ $(EXTRACTRC) `find -name \*.ui -o -name \*.rc` > rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmldap.pot
+