summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-12-13 18:35:41 +0100
committerSlávek Banko <slavek.banko@axis.cz>2018-12-13 18:42:05 +0100
commit0557917aa98c792eb316ce176c97849f3e7bdb3e (patch)
tree4ee596079b11ec246e6355a33563aa41d3e0e364 /src/Makefile.am
parent63cec2ebf40be205347bd97b53ad2a77dbcdcb38 (diff)
downloadkcpuload-0557917aa98c792eb316ce176c97849f3e7bdb3e.tar.gz
kcpuload-0557917aa98c792eb316ce176c97849f3e7bdb3e.zip
Fix structure of directories
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..b2b0e42
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,50 @@
+
+############################################################################
+# #
+# Main KCPULoad sources. #
+# #
+# KCPULoad is copyright (c) 1999-2000, Markus Gustavsson #
+# (c) 2002, Ben Burton #
+# #
+# This program is free software; you can redistribute it and/or modify #
+# it under the terms of the GNU General Public License as published by #
+# the Free Software Foundation; either version 2 of the License, or #
+# (at your option) any later version. #
+# #
+############################################################################
+
+INCLUDES = $(all_includes)
+
+bin_PROGRAMS = kcpuload
+
+kcpuload_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_TQT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor
+
+kcpuload_LDADD = $(LIB_TDEUI)
+
+kcpuload_SOURCES = \
+ icontoggleaction.cpp \
+ kcpudock.cpp \
+ kcpuload.cpp \
+ kcpuproc.cpp \
+ main.cpp \
+ statdock.cpp \
+ speeddialog.cpp \
+ statpopup.cpp
+
+noinst_HEADERS = \
+ icontoggleaction.h \
+ kcpudock.h \
+ kcpuload.h \
+ kcpuproc.h \
+ speeddialog.h \
+ statdock.h \
+ statpopup.h
+
+METASOURCES = AUTO
+
+appsdir = $(kde_appsdir)/System
+apps_DATA = kcpuload.desktop
+
+KDE_ICON = kcpuload
+
+EXTRA_DIST = AUTHORS COPYING ChangeLog INSTALL README TODO