summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..9572872
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,24 @@
+
+INCLUDES= $(all_includes)
+
+bin_PROGRAMS = kerberostray
+
+kerberostray_SOURCES = main.cpp toplevel.cpp tealist.cpp timeedit.cpp
+
+kerberostray_METASOURCES = AUTO
+kerberostray_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -lktexteditor
+
+# LIB_KIO needed for KNotifyDialog
+kerberostray_LDADD = $(LIB_TDEUI) $(LIB_KIO)
+
+KDE_ICON = kerberostray
+
+KDE_OPTIONS = nofinal
+
+kerberostrayicondir = $(kde_datadir)/kerberostray/icons
+kerberostrayicon_ICON = AUTO
+
+messages:
+ $(XGETTEXT) $(kerberostray_SOURCES) -o $(podir)/kerberostray.pot
+
+xdg_apps_DATA = kerberostray.desktop