summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 11:00:00 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 11:11:00 +0900
commitb6dba7c2380157cb1ec589cf6ddba9176d41ac1a (patch)
tree39273b80dd6f5b4735262c7217a58d7f389690d0 /CMakeLists.txt
parent3a8356c8299e7726f7fe7bf5716ce08b19312e27 (diff)
downloadkmplayer-b6dba7c2380157cb1ec589cf6ddba9176d41ac1a.tar.gz
kmplayer-b6dba7c2380157cb1ec589cf6ddba9176d41ac1a.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c248c49..fd8565c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -32,11 +36,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )