summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2012-07-11 03:36:42 +0200
committerSlávek Banko <slavek.banko@axis.cz>2012-07-11 03:47:55 +0200
commit8fe6f08227059c8cddc686888fb3e402b83c9eff (patch)
tree8966907d5b5cc3ecdd6bb86bc845e605f07926b8 /configure.in
parentefeb4d69d6d954caeb700e0a33ca0a8ae7d4e166 (diff)
downloadkmplayer-8fe6f08227059c8cddc686888fb3e402b83c9eff.tar.gz
kmplayer-8fe6f08227059c8cddc686888fb3e402b83c9eff.zip
Changed screen saver control to use fake events
This closes Bug 1031
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5911553..102c19a 100644
--- a/configure.in
+++ b/configure.in
@@ -123,6 +123,35 @@ if test x$have_expat = xyes -a x$want_expat = xyes; then
AC_SUBST(LIB_EXPAT)
fi
+dnl -------------------------
+dnl check for XTest extension
+dnl -------------------------
+
+AC_ARG_WITH([xtest], [AS_HELP_STRING([--without-xtest], [build without XTest support])],,
+ [with_xtest=yes])
+
+CFLAGS_XTEST=""
+LIB_XTEST=""
+
+if test "$with_xtest" != "no" ; then
+ AC_MSG_CHECKING([for XTest extension])
+
+ if "$PKG_CONFIG" --exists xtst ; then
+ with_xtest=yes
+ CFLAGS_XTEST=`"$PKG_CONFIG" --cflags xtst`
+ LIB_XTEST=`"$PKG_CONFIG" --libs xtst`
+ AC_DEFINE([HAVE_XTEST],,[XTest extension available])
+ AC_MSG_RESULT([yes])
+ else
+ with_xtest=no
+ AC_MSG_RESULT([no])
+ fi
+fi
+
+AC_SUBST([CFLAGS_XTEST])
+AC_SUBST([LIB_XTEST])
+
+
KDE_CHECK_HEADER(xine.h,
have_xine=yes,
have_xine=no)