summaryrefslogtreecommitdiffstats
path: root/knowit.spec
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-17 02:48:30 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-17 02:48:30 +0000
commite1481e0a7c066357dfb67136f331b5f069d94f3c (patch)
tree19599adc9a54e8295402ceb25d6f2ea42edea439 /knowit.spec
downloadknowit-e1481e0a7c066357dfb67136f331b5f069d94f3c.tar.gz
knowit-e1481e0a7c066357dfb67136f331b5f069d94f3c.zip
Added abandoned KDE3 version of knowit
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/knowit@1091582 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'knowit.spec')
-rw-r--r--knowit.spec43
1 files changed, 43 insertions, 0 deletions
diff --git a/knowit.spec b/knowit.spec
new file mode 100644
index 0000000..7d0ded9
--- /dev/null
+++ b/knowit.spec
@@ -0,0 +1,43 @@
+%define version 0.10
+%define name knowit
+%define release 1
+Name: %{name}
+Version: %{version}
+Release: %{release}
+Packager: Michal Rudolf
+Source: %{name}-%{version}.tar.bz2
+BuildRoot: /tmp/build-%{name}-%{version}-%{release}
+Copyright: GPL
+Group: X11/KDE/Utilities
+Summary: knowledge management program for KDE
+
+%description
+KnowIt is a simple tool for managing notes. It is similar to
+TuxCards, but KDE-based. Notes are organized in tree-like hierarchy,
+texts are in RichText format, so bold, italic and lists are supported,
+with more to come.
+
+%prep
+rm -rf $RPM_BUILD_ROOT
+
+%setup -q
+
+%build
+CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS -DNO_DEBUG" \
+./configure --prefix=$KDEDIR --with-install-root=$RPM_BUILD_ROOT # --enable-final
+make
+
+%install
+make prefix=$RPM_BUILD_ROOT$KDEDIR install-strip
+
+cd $RPM_BUILD_ROOT
+find . -type d | sed '1,2d;s,^\.,\%attr(-\,root\,root) \%dir ,' > $RPM_BUILD_DIR/file.list.%{name}
+find . -type f | sed 's,^\.,\%attr(-\,root\,root) ,' >> $RPM_BUILD_DIR/file.list.%{name}
+find . -type l | sed 's,^\.,\%attr(-\,root\,root) ,' >> $RPM_BUILD_DIR/file.list.%{name}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+rm -rf $RPM_BUILD_DIR/%{name}-%{version}
+rm -f $RPM_BUILD_DIR/file.list.%{name}
+
+%files -f ../file.list.%{name}