summaryrefslogtreecommitdiffstats
path: root/kchart/kdchart/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
commit8362bf63dea22bbf6736609b0f49c152f975eb63 (patch)
tree0eea3928e39e50fae91d4e68b21b1e6cbae25604 /kchart/kdchart/Makefile.am
downloadkoffice-8362bf63dea22bbf6736609b0f49c152f975eb63.tar.gz
koffice-8362bf63dea22bbf6736609b0f49c152f975eb63.zip
Added old abandoned KDE3 version of koffice
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/koffice@1077364 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kchart/kdchart/Makefile.am')
-rw-r--r--kchart/kdchart/Makefile.am94
1 files changed, 94 insertions, 0 deletions
diff --git a/kchart/kdchart/Makefile.am b/kchart/kdchart/Makefile.am
new file mode 100644
index 00000000..0538e50c
--- /dev/null
+++ b/kchart/kdchart/Makefile.am
@@ -0,0 +1,94 @@
+lib_LTLIBRARIES = libkdchart.la
+
+libkdchart_la_SOURCES = KDChart.cpp \
+ KDChartAreaPainter.cpp \
+ KDChartAxesPainter.cpp \
+ KDChartAxisParams.cpp \
+ KDChartBarPainter.cpp \
+ KDChartBaseSeries.cpp \
+ KDChartBWPainter.cpp \
+ KDChartCustomBox.cpp \
+ KDChartDataIntern.cpp \
+ KDChartHiLoPainter.cpp \
+ KDChartLinesPainter.cpp \
+ KDChartPainter.cpp \
+ KDChartParams.cpp \
+ KDChartParams_frame.cpp\
+ KDChartParams_io.cpp \
+ KDChartPiePainter.cpp \
+ KDChartPlaneSeries.cpp \
+ KDChartPolarPainter.cpp \
+ KDChartPropertySet.cpp \
+ KDChartRingPainter.cpp \
+ KDChartSeriesCollection.cpp \
+ KDChartTableBase.cpp \
+ KDChartTextPiece.cpp \
+ KDChartVectorSeries.cpp \
+ KDChartVectorTable.cpp \
+ KDChartWidget.cpp \
+ KDDrawText.cpp \
+ KDFrame.cpp \
+ KDFrameProfileSection.cpp \
+ KDXMLTools.cpp \
+ KDChartEnums.cpp \
+ KDChartAxisParamsWrapper.cpp \
+ KDChartCustomBoxWrapper.cpp \
+ KDChartParamsWrapper.cpp \
+ KDChartTableDataWrapper.cpp
+ #KDChartObjectFactory.cpp
+ #KDChartWrapperFactory.cpp
+
+libkdchart_la_LDFLAGS = $(all_libraries) -no-undefined
+libkdchart_la_LIBADD = $(LIB_QT) $(LIB_KDECORE)
+
+noinst_HEADERS = KDChart.h \
+ KDChartAreaPainter.h \
+ KDChartAxesPainter.h \
+ KDChartBarPainter.h \
+ KDChartBaseSeries.h \
+ KDChartBWPainter.h \
+ KDChartDataIntern.h \
+ KDChartDataRegion.h \
+ KDChartHiLoPainter.h \
+ KDChartLinesPainter.h \
+ KDChartNotEnoughSpaceException.h \
+ KDChartUnknownTypeException.h \
+ KDChartPainter.h \
+ KDChartPiePainter.h \
+ KDChartPlaneSeries.h \
+ KDChartPolarPainter.h \
+ KDChartRingPainter.h \
+ KDChartSeriesCollection.h \
+ KDChartTextPiece.h \
+ KDChartUnknownTypeException.h \
+ KDChartVectorSeries.h \
+ KDDrawText.h \
+ KDXMLTools.h
+METASOURCES = AUTO
+
+INCLUDES = $(KOFFICECORE_INCLUDES) -I$(srcdir)/.. -I$(srcdir) $(all_includes)
+
+include_HEADERS = KDChartTableBase.h \
+ KDChartListTable.h \
+ KDChartVectorTable.h \
+ KDChartTable.h \
+ KDChartParams.h \
+ KDFrameProfileSection.h \
+ KDChartPropertySet.h \
+ KDChartDataIntern.h \
+ KDChartDataRegion.h \
+ KDFrame.h \
+ KDChartGlobal.h \
+ KDChartWidget.h \
+ KDChartCustomBox.h \
+ KDChartEnums.h \
+ KDChartTextPiece.h \
+ KDChartAxisParams.h \
+ kdchart_export.h \
+ KDChartCustomBoxWrapper.h \
+ KDChartWrapperFactory.h \
+ KDChartAxisParamsWrapper.h \
+ KDChartParamsWrapper.h \
+ KDChartTableDataWrapper.h \
+ KDChartObjectFactory.h
+