summaryrefslogtreecommitdiffstats
path: root/kexi/main/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
commit8362bf63dea22bbf6736609b0f49c152f975eb63 (patch)
tree0eea3928e39e50fae91d4e68b21b1e6cbae25604 /kexi/main/Makefile.am
downloadkoffice-8362bf63dea22bbf6736609b0f49c152f975eb63.tar.gz
koffice-8362bf63dea22bbf6736609b0f49c152f975eb63.zip
Added old abandoned KDE3 version of koffice
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/koffice@1077364 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kexi/main/Makefile.am')
-rw-r--r--kexi/main/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/kexi/main/Makefile.am b/kexi/main/Makefile.am
new file mode 100644
index 00000000..8786c7cf
--- /dev/null
+++ b/kexi/main/Makefile.am
@@ -0,0 +1,35 @@
+include $(top_srcdir)/kexi/Makefile.global
+
+lib_LTLIBRARIES = libkeximain.la
+libkeximain_la_SOURCES = \
+ keximainwindowimpl.cpp \
+ kexistatusbar.cpp \
+ kexinamewidget.cpp kexinamedialog.cpp \
+ kexinewstuff.cpp kexifinddialogbase.ui kexifinddialog.cpp
+
+libkeximain_la_LDFLAGS = -no-undefined $(KDE_RPATH) $(all_libraries) \
+ $(VER_INFO) -Wnounresolved
+
+SUBDIRS = startup printing .
+
+libkeximain_la_LIBADD = $(top_builddir)/kexi/kexidb/libkexidb.la $(top_builddir)/kexi/core/libkexicore.la \
+ $(top_builddir)/kexi/kexiutils/libkexiutils.la \
+ $(top_builddir)/kexi/main/startup/libkeximainstartup.la \
+ $(top_builddir)/kexi/main/printing/libkeximainprinting.la \
+ $(top_builddir)/lib/koproperty/libkoproperty.la \
+ $(top_builddir)/kexi/widget/libkexiextendedwidgets.la \
+ $(LIB_KFEEDBACK) $(LIB_KEXI_KMDI) $(LIB_KNEWSTUFF) $(LIB_KIO) $(LIB_KDEPRINT)
+
+#disabled ../migration/libkeximigrate.la
+
+INCLUDES = $(INC_KFEEDBACK) $(LIB_KEXI_KMDI_INCLUDES) \
+ -I$(top_builddir)/lib/kofficeui -I$(top_srcdir)/lib/kofficeui \
+ -I$(top_srcdir)/kexi -I$(top_srcdir)/kexi/core \
+ -I$(top_srcdir)/kexi/main \
+ -I$(top_srcdir)/kexi/main/startup -I$(top_srcdir)/kexi/widget \
+ -I$(top_srcdir)/kexi/migration -I$(top_srcdir)/lib -I$(top_srcdir)/lib/kofficecore \
+ $(all_includes)
+
+noinst_HEADERS = ksplitter.h keximainwindowimpl_p.h
+
+METASOURCES = AUTO