summaryrefslogtreecommitdiffstats
path: root/krita/plugins/tools/selectiontools/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
commit8362bf63dea22bbf6736609b0f49c152f975eb63 (patch)
tree0eea3928e39e50fae91d4e68b21b1e6cbae25604 /krita/plugins/tools/selectiontools/Makefile.am
downloadkoffice-8362bf63dea22bbf6736609b0f49c152f975eb63.tar.gz
koffice-8362bf63dea22bbf6736609b0f49c152f975eb63.zip
Added old abandoned KDE3 version of koffice
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/koffice@1077364 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'krita/plugins/tools/selectiontools/Makefile.am')
-rw-r--r--krita/plugins/tools/selectiontools/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/krita/plugins/tools/selectiontools/Makefile.am b/krita/plugins/tools/selectiontools/Makefile.am
new file mode 100644
index 00000000..a3fc336f
--- /dev/null
+++ b/krita/plugins/tools/selectiontools/Makefile.am
@@ -0,0 +1,55 @@
+kde_services_DATA = kritaselectiontools.desktop
+
+# all_includes must remain last!
+INCLUDES = -I$(srcdir)/../../../sdk \
+ -I$(srcdir)/../../../core \
+ -I$(srcdir)/../../../kritacolor/ \
+ -I$(srcdir)/../../../ui \
+ -I$/../../../ui \
+ $(KOFFICE_INCLUDES) \
+ $(all_includes)
+
+kritaselectiontools_la_SOURCES = kis_tool_move_selection.cc \
+ kis_tool_select_brush.cc kis_tool_select_contiguous.cc kis_tool_select_elliptical.cc \
+ kis_tool_select_eraser.cc kis_tool_select_outline.cc kis_tool_select_polygonal.cc \
+ kis_tool_select_rectangular.cc selection_tools.cc
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = kritaselectiontools.la
+
+noinst_HEADERS = \
+ selection_tools.h \
+ kis_tool_select_outline.h \
+ kis_tool_select_polygonal.h \
+ kis_tool_select_rectangular.h \
+ kis_tool_select_brush.h \
+ kis_tool_select_eraser.h \
+ kis_tool_select_contiguous.h \
+ kis_tool_select_elliptical.h
+
+
+kritaselectiontools_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kritaselectiontools_la_LIBADD = ../../../libkritacommon.la
+
+kritaselectiontools_la_METASOURCES = AUTO
+
+KDE_OPTIONS = nofinal
+
+kritapics_DATA = \
+ tool_rect_selection.png \
+ tool_eraser_selection.png \
+ tool_brush_selection.png \
+ tool_contiguous_selection.png \
+ tool_elliptical_selection.png \
+ tool_outline_selection.png \
+ tool_polygonal_selection.png \
+ tool_rectangular_selection_cursor.png \
+ tool_eraser_selection_cursor.png \
+ tool_brush_selection_cursor.png \
+ tool_contiguous_selection_cursor.png \
+ tool_elliptical_selection_cursor.png \
+ tool_outline_selection_cursor.png \
+ tool_polygonal_selection_cursor.png
+
+kritapicsdir = $(kde_datadir)/krita/pics
+