summaryrefslogtreecommitdiffstats
path: root/lib/kopalette/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
commit8362bf63dea22bbf6736609b0f49c152f975eb63 (patch)
tree0eea3928e39e50fae91d4e68b21b1e6cbae25604 /lib/kopalette/Makefile.am
downloadkoffice-8362bf63dea22bbf6736609b0f49c152f975eb63.tar.gz
koffice-8362bf63dea22bbf6736609b0f49c152f975eb63.zip
Added old abandoned KDE3 version of koffice
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/koffice@1077364 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'lib/kopalette/Makefile.am')
-rw-r--r--lib/kopalette/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/lib/kopalette/Makefile.am b/lib/kopalette/Makefile.am
new file mode 100644
index 00000000..ad9a29e0
--- /dev/null
+++ b/lib/kopalette/Makefile.am
@@ -0,0 +1,25 @@
+# all_includes must remain last!
+INCLUDES = -I$(srcdir) \
+ $(KOFFICECORE_INCLUDES) \
+ $(all_includes)
+
+lib_LTLIBRARIES = libkopalette.la
+
+libkopalette_la_SOURCES = \
+ kopalette.cc \
+ kopalettemanager.cc \
+ kotoolboxpalette.cc \
+ kotabpalette.cc
+
+libkopalette_la_LDFLAGS = -version-info 1:0:0 -no-undefined $(all_libraries)
+libkopalette_la_LIBADD = $(LIB_KOFFICECORE)
+
+include_HEADERS = \
+ kopalettemanager.h
+
+noinst_HEADERS = \
+ kopalette.h \
+ kotabpalette.h \
+ kotoolboxpalette.h
+
+METASOURCES = AUTO