summaryrefslogtreecommitdiffstats
path: root/plugins/scan/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
commit8362bf63dea22bbf6736609b0f49c152f975eb63 (patch)
tree0eea3928e39e50fae91d4e68b21b1e6cbae25604 /plugins/scan/Makefile.am
downloadkoffice-8362bf63dea22bbf6736609b0f49c152f975eb63.tar.gz
koffice-8362bf63dea22bbf6736609b0f49c152f975eb63.zip
Added old abandoned KDE3 version of koffice
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/koffice@1077364 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'plugins/scan/Makefile.am')
-rw-r--r--plugins/scan/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/plugins/scan/Makefile.am b/plugins/scan/Makefile.am
new file mode 100644
index 00000000..9df2b9bd
--- /dev/null
+++ b/plugins/scan/Makefile.am
@@ -0,0 +1,24 @@
+kwordrcdir = $(kde_datadir)/kword/kpartplugins
+kwordrc_DATA = scan-kword.rc
+
+kritarcdir = $(kde_datadir)/krita/kpartplugins
+kritarc_DATA = scan-krita.rc
+
+kpresenterrcdir = $(kde_datadir)/kpresenter/kpartplugins
+kpresenterrc_DATA = scan-kpresenter.rc
+
+EXTRA_DIST = $(kwordrc_DATA) $(kritarc_DATA) $(kpresenterrc_DATA)
+
+INCLUDES = $(KOFFICE_INCLUDES) $(all_includes)
+kde_module_LTLIBRARIES = kofficescan.la
+
+kofficescan_la_SOURCES = scan.cpp
+noinst_HEADERS = scan.h
+
+kofficescan_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kofficescan_la_LIBADD = $(LIB_KPARTS) $(LIB_KIO) $(LIB_KOFFICECORE)
+
+kofficescan_la_METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kscan_plugin.pot