summaryrefslogtreecommitdiffstats
path: root/krita/colorspaces/wetsticky/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'krita/colorspaces/wetsticky/Makefile.am')
-rw-r--r--krita/colorspaces/wetsticky/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/krita/colorspaces/wetsticky/Makefile.am b/krita/colorspaces/wetsticky/Makefile.am
new file mode 100644
index 00000000..70eeb06d
--- /dev/null
+++ b/krita/colorspaces/wetsticky/Makefile.am
@@ -0,0 +1,25 @@
+kde_services_DATA = kritawsplugin.desktop
+INCLUDES = -I$(srcdir)/../../sdk \
+ -I$(srcdir)/../../core \
+ -I$(srcdir)/../../core/color_strategy \
+ -I$(srcdir)/../../../kritacolor/color_strategy/ \
+ -I$(srcdir)/../../../color_strategy/ \
+ -I$(srcdir)/../../ui \
+ $(KOFFICE_INCLUDES) \
+ -I$(interfacedir) \
+ $(KOPAINTER_INCLUDES) \
+ $(all_includes)
+
+kde_module_LTLIBRARIES = kritawsplugin.la
+
+kritawsplugin_la_SOURCES = wet_sticky_plugin.cc kis_wet_sticky_colorspace.cc kis_ws_engine_filter.cc
+noinst_HEADERS = wet_sticky_plugin.h kis_wet_sticky_colorspace.h kis_ws_engine_filter.h
+
+kritawsplugin_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kritawsplugin_la_LIBADD = ../../kritacolor/libkritacolor.la
+
+kritawsplugin_la_METASOURCES = AUTO
+
+SUBDIRS=brushop
+
+