summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2019-03-21 23:06:29 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2019-03-21 23:06:29 +0900
commit5ea733c60c8f6323cf94b726b997e8e22bca191f (patch)
tree663247da178c64bbadaba93c6c3093d795975ca7 /CMakeLists.txt
parent99c2252141beff717bcc1f54cbae4ba75923c81c (diff)
downloadkpilot-5ea733c60c8f6323cf94b726b997e8e22bca191f.tar.gz
kpilot-5ea733c60c8f6323cf94b726b997e8e22bca191f.zip
Fixed support for tests in cmake.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 647af0e..defcaba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,7 +27,7 @@ include( CheckIncludeFile )
include( CheckFunctionExists )
include( CheckLibraryExists )
include( CheckSymbolExists )
-
+enable_testing( )
#### include our cmake modules ##################
@@ -73,6 +73,8 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( lib )
add_subdirectory( kpilot )
add_subdirectory( conduits )
+add_subdirectory( tests )
+
tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )