summaryrefslogtreecommitdiffstats
path: root/conduits/knotes/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
commitcb7eddb91455a69cf66fcd717e91a51ca5e2cfef (patch)
treecf5546e4d7c44370fbe9ca2be937bd254f30ebaa /conduits/knotes/Makefile.am
downloadkpilot-cb7eddb91455a69cf66fcd717e91a51ca5e2cfef.tar.gz
kpilot-cb7eddb91455a69cf66fcd717e91a51ca5e2cfef.zip
Moved kpilot from kdepim to applications, as the core Trinity libraries should not contain hardware-dependent software
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kpilot@1221127 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'conduits/knotes/Makefile.am')
-rw-r--r--conduits/knotes/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/conduits/knotes/Makefile.am b/conduits/knotes/Makefile.am
new file mode 100644
index 0000000..db4cff3
--- /dev/null
+++ b/conduits/knotes/Makefile.am
@@ -0,0 +1,21 @@
+INCLUDES= $(PISOCK_INCLUDE) -I$(top_srcdir) -I$(top_srcdir)/kpilot/lib $(all_includes)
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = knotes-conduit.desktop
+
+kde_module_LTLIBRARIES = conduit_knotes.la
+
+
+conduit_knotes_la_SOURCES = \
+ knotesconduitSettings.kcfgc \
+ knotes-factory.cc \
+ knotes-setup.cc \
+ knotes-action.cc \
+ setup_base.ui
+
+conduit_knotes_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+conduit_knotes_la_LIBADD = ../../lib/libkpilot.la $(LIB_KDEUI)
+
+kde_kcfg_DATA = knotesconduit.kcfg