summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt61
1 files changed, 61 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..5634bb3
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,61 @@
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+##### subfolders
+
+add_subdirectory( backends )
+add_subdirectory( datablocks )
+add_subdirectory( dialogs )
+add_subdirectory( exporters )
+add_subdirectory( importers )
+add_subdirectory( widgets )
+
+
+##### krecipes (executable)
+
+tde_add_executable( krecipes AUTOMOC
+ SOURCES
+ main.cpp krecipes.cpp krecipesview.cpp pref.cpp
+ krecipesiface.skel krecipesdbiface.skel
+ propertycalculator.cpp setupwizard.cpp
+ shoppingcalculator.cpp kstartuplogo.cpp
+ recipeactionshandler.cpp recipefilter.cpp
+ convert_sqlite3.cpp klomanager.cpp
+ LINK
+ krecipesdbs-static krecipesexporters-static krecipesimporters-static
+ krecipesdialogs-static krecipeswidgets-static datablocks-static
+ tdecore-shared tdeui-shared tdeio-shared tdeparts-shared
+ tdefx-shared tdehtml-shared DCOP-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other files
+
+install(
+ FILES krecipes.xpm
+ DESTINATION ${SHARE_INSTALL_PREFIX}/pixmaps
+)
+
+install(
+ FILES krecipesui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/krecipes
+)
+
+tde_create_translated_desktop(
+ SOURCE krecipes.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)
+
+tde_install_icons( DESTINATION ${SHARE_INSTALL_PREFIX}/icons )