summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-10-27 16:49:13 +0200
committerSlávek Banko <slavek.banko@axis.cz>2018-10-27 16:49:25 +0200
commite023691c157597570525a90ecb650e080c662fcb (patch)
treefdfe8911541f2cd398c75e19e24c8b04f663f1de /CMakeLists.txt
parentededcc28b46bb4a33cddae207b95ccb8722885a4 (diff)
downloadkrename-e023691c157597570525a90ecb650e080c662fcb.tar.gz
krename-e023691c157597570525a90ecb650e080c662fcb.zip
Added controlled conversions to char* instead of automatic ascii conversions.
The definition of -UTQT_NO_ASCII_CAST is no longer needed. Fix unnecessary use of TQString() over i18n(). Resolved use of deprecated NetAccess methods. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 76f3a66..365dc48 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,7 +58,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UTQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined" )