summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 11:16:26 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 11:13:20 +0900
commita2b47101261e317b80f6fe9b7197363e39c6931a (patch)
tree9f9484277e535511bef894e5da20e8022663f10f /CMakeLists.txt
parent6da2ba677c47d91e60cc819e29620bc4c919bfaa (diff)
downloadksensors-a2b47101261e317b80f6fe9b7197363e39c6931a.tar.gz
ksensors-a2b47101261e317b80f6fe9b7197363e39c6931a.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9d313dd..900e309 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )