summaryrefslogtreecommitdiffstats
path: root/plugins/rssfeed/rss/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/rssfeed/rss/Makefile.am')
-rw-r--r--plugins/rssfeed/rss/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/plugins/rssfeed/rss/Makefile.am b/plugins/rssfeed/rss/Makefile.am
new file mode 100644
index 0000000..75b570a
--- /dev/null
+++ b/plugins/rssfeed/rss/Makefile.am
@@ -0,0 +1,20 @@
+INCLUDES = \
+ -I$(top_srcdir)/src \
+ $(all_includes)
+
+noinst_LTLIBRARIES = \
+ librsslocal.la
+
+noinst_HEADERS = article.h document.h global.h image.h textinput.h \
+ loader.h librss.h
+
+librsslocal_la_SOURCES = article.cpp document.cpp image.cpp textinput.cpp \
+ tools_p.cpp loader.cpp
+
+librsslocal_la_METASOURCES = AUTO
+
+check_PROGRAMS = testlibrss
+testlibrss_SOURCES = testlibrss.cpp
+testlibrss_LDFLAGS = $(all_libraries)
+testlibrss_LDADD = librsslocal.la $(LIB_KIO)
+KDE_CXXFLAGS = $(USE_EXCEPTIONS) $(USE_RTTI)